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Uzyskanie wyników w drodze symulacji

opracowanie: Bartosz Pękosławski

Na stronie przedmiotu dostępne jest archiwum z biblioteką elementów, które należy rozpakować do katalogu 
projektu. Na stronie znajdują się również linki do:

• instrukcji instalacji biblioteki;
• skróconej instrukcji ogólnej obsługi pakietu MicroSim/OrCAD, która zawiera m.in. informacje o: 

wstawianiu elementów, rysowaniu połączeń, konfiggurowaniu i uruchamianiu symulacji, dodawaniu 
znaczników pomiarowych, poszukiwaniu źródeł błędów symulacji.

Pracę w pakiecie MicroSim/OrCAD należy rozpocząć i prowadzić ściśle według wskazówek podanych w 
powyższej instrukcji ogólnej. Potrzebne funkcje są opisane w instrukcji ogólnej.

Analizie należy poddać układy odpowiadające badanym doświadczalnie, jednak z niezbędnymi modyfigkacjami 
obejmującymi (patrz rysunki poniżej):

• zastąpienie układu sterowania dla przekształtnika o działaniu przełączającym uproszczonym układem 
złożonym ze modulatora PWM i wzmacniacza błędu.
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Rysunek 1: Schemat układu symulacyjnego przekształtnika o działaniu ciągłym 



 

1. Uruchom pakiet MicroSim/OrCAD zgodnie z instrukcją ogólną. Utwórz nowy projekt zgodnie z 
instrukcją ogólną .

2. Otwórz edytor schematów i od razu zapisz pusty schemat w katalogu projektu.

3. Do katalogu projektu rozpakuj archiwum z biblioteką elementów. Zainstaluj bibliotekę w projekcie 
według instrukcji na stronie.

4. Wprowadź schemat układu zgodnie z rysunkiem 1, przy czym:

a) Środowisko   MicroSim  umożliwia   wprowadzanie   liczb   wraz   z   przedrostkami   jednostek.  
W przypadku opisu obwodów (m.in. w programie Schematic) są to: f, p, n, u (oznacza μ), m, k, Meg
(oznacza M), G; przy czym wielkość liter nie ma znaczenia. W przypadku programu Probe są to: f, p,
n, u, m, k, M, G, przy czym wielkość liter jest znacząca. W takiej formie są też wyświetlane wyniki w
programie Probe. Jednostki lub ich przedrostki nie mogą być oddzielone od liczb spacją. Symulatory
z  rodziny  SPICE  posiadają  własny  język  opisu  obwodów,  w  którym  znakiem dziesiętnym jest
kropka  (czyli  nie  przecinek).  Format  ten  dotyczy  wszystkich  programów  pakietu  MicroSim,
niezależnie od ustawień systemu operacyjnego.

b) nazwy modeli tranzystora i układu scalonego są tożsame z ich oznaczeniami;

c) w obwodzie należy zdefigniować umowny węzeł masy, któremu zostanie przypisany numer 0 i 
potencjał 0 V – element GND_ANALOG.

5. Zmodyfigkuj oznaczenie każdego elementu tak, by kończyło się pełnym (nie jednocyfrowym) numerem 
zespołu.

6. Skonfigguruj symulację (menu Analysis ‣ Setup albo przycisk Setup Analysis):

a) uaktywnij analizę czasową (Transient), dezaktywuj wszelkie inne;

b) kliknij Transient w celu otwarcia okna parametrów i wprowadź:
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Rysunek 2: Schemat układu symulacyjnego przekształtnika o działaniu przełączającym



▪ czas końcowy analizy (Final Time) – 0,1 s;

▪ krok zrzutu wyników do pliku tekstowego (Print Step, parametr nie używany w tej symulacji) – 
dowolny mniejszy od czasu końcowego;

▪ czas bez rejestracji wyników (No-Print Delay) – 0 (tj. rejestracja od początku symulacji);

▪ maksymalny krok czasowy (Step Ceiling) – brak ustawionego;

c) upewnij się, że opcja Skip initial transient solution nie jest zaznaczona.

7. W odpowiednim i nadającym się do tego celu miejscu dodaj znaczniki umożliwiające pomiar prądu 
wejściowego (źródło V1) i obciążenia (rezystor RL). 

8. Uruchom symulację. Upewnij się, że wykreślony przebieg prądu jest zgodny z zasadą działania układu w 
aspekcie kształtu oraz częstotliwości.

9. Dodaj nowy podwykres. Dodając odpowiednie znaczniki na schemacie, wyświetl na nim przebiegi 
napięcia wejściowego ui , napięcia ugs i napięcia wyjściowego uo, przy czym:

▪ zgodnie z instrukcją ogólną obsługi pakietu MicroSim/OrCAD, do wyświetlenia przebiegów nie 
jest konieczne ponowne uruchamianie symulacji, które usunęłoby dodany podwykres;

▪ znacznik potencjału może być wykorzystywany do pomiaru tylko takich napięć, które są 
odniesione do masy przypisanej w pkt. 4.c; inne napięcia muszą być mierzone znacznikiem 
napięcia (nie potencjału);

▪ w przypadku znaczników napięcia należy zachować polaryzację mierzonego napięcia zgodnie z 
rysunkiem powyżej (dla znacznika jest ona wskazywana przez znaki „+” i „−” w kółkach).

10. Upewnij się, że zgodnie z prawami i konwencjami teorii obwodów, wszystkie mierzone przebiegi mają w 
każdej chwili jednakowy znak. W przeciwnym razie:

a) sprawdź zgodność polaryzacji mierzonych napięć zgodnie z rysunkiem 1;

b) do prądu zastosuj uwagę:

Z topologii obwodu mocy i napięciowego prawa Kirchhoffaa wynika, że prąd jest dodatni dla dodatniego
napięcia i ujemny dla ujemnego, zgodnie  z  konwencją  strzałkowania  przyjętą  w  elektrotechnice.
Jeżeli  znak  prądu wyświetlanego w programie Probe jest ujemny dla dodatniego napięcia, to wynika to
wyłącznie z przyłożenia znacznika w  programie  Schematics  do  końcówki,  której  prąd  jest  umownie
skierowany  przeciwnie   niż rzeczywisty  prąd  w  obwodzie.   Użytkownik  nie  ma  wpływu  na
strzałkowanie   napięć   i  prądów  –  jest   to  z  góry  zdefinniowane  w  modelach  i   symbolach
elementów,  bez  związku  z konkretnym  obwodem.  W  takiej  sytuacji  należy  skorygować  przebieg
przez  przełożenie znacznika prądowego na przeciwległą końcówkę elementu w programie Schematics
(powtarzanie  symulacji  nie  jest  konieczne,  jeżeli  pakiet  MicroSim  jest  poprawnie  zainstalowany  i
obsługiwany) albo przez dodanie znaku „-” w definnicji przebiegu w programie Probe po dwukrotnym
kliknięciu na jego opisie pod wykresem.

11. Dodaj trzeci podwykres i skopiuj na niego przebieg prądu. Zmodyfigkuj jego równanie tak, by uzyskać 
wzór na moc wejściową pi, dodając odpowiedni operator arytmetyczny i przepisując podpis przebiegu 
napięcia wejściowego ui wyświetlany pod drugim podwykresem zgodnie z punktami:

a) utwórz  podwykres  –  menu  Plot  ‣  Add  Plot;  dodany  podwykres  powinien  być  wskazany  jako
aktywny  napisem  „SEL”  –  w  przeciwnm  razie  go wybrać  klikając  gdziekolwiek wewnątrz; 

b) z  dolnego  podwykresu  skopiuj  na  górny  przebieg  prądu  –  zaznacz  go  klikając  na  opisie  pod
wykresem (opis powinien zostać podświetlony innym kolorem),  a następnie użyj menu, ikon lub
klawiatury w celu wywołania funkcji Kopiuj i Wklej; 
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c) dwukrotnie  kliknij  na  opisie  skopiowanego  przebiegu  (pod  górnym  podwykresem)  i zmodyfigkuj
opisujące go wyrażenie matematyczne (Trace Expression) tak, aby wyrażało moc;  zrozumiałe  dla
programu  Probe oznaczenia  wielkości  należy  odczytać  z  opisów  przebiegów  pod  dolnym
podwykresem; należy  zwrócić  uwagę,  że  uzyskana krzywa musi przyjmować wartości dodatnie.
Jeżeli w formule występuje połączenie znaku mnożenia i minusa, wyrażenie z minusem należy ująć
w  nawiasy.   W  przeciwnym  razie   może   wystąpić   błąd   obliczeniowy,   który   spowoduje
zamknięcie aplikacji.

12. Powtórz punkt 11 dla mocy wyjściowej.

13. Jeżeli wszystkie ustawienia wykresu są poprawne:

a) korzystając z funkcji Display Control (menu Window albo Tools zależnie od wersji pakietu), zachowaj 
uzyskaną konfiggurację wykresu;

b) w oknie schematu, z menu Analysis wybierz Probe Setup i zaznacz Restore last Probe session w celu 
wyeliminowania konieczności przywracania konfigguracji po każdej nowej symulacji.

14. Aktywuj kursory ikoną Toggle cursor albo z menu Tools ‣ Cursor ‣ Display. Kursory umieszcza się 
następnie na konkretnym przebiegu przez kliknięcie na jego znaczniku grafigcznym (nie podpisie 
tekstowym) pod wykresem – lewym klawiszem myszy dla kursora 1, prawym dla kursora 2.

15. Dla napięcia wejściowego podanego przez prowadzącego, uzyskaj i zapisz dane zastępujące wyniki 
pomiarów:

a) moc wejściową Pi ;

b) moc wyjściową Po;

c) prąd wejściowy Ii i wyjściowy Io;

d) napięcie wyjściowe (na odbiorniku) Uo

16. Zapisz obraz przebiegów (menu Window ‣ Copy to Clipboard).

17. Skonfigguruj symulację (menu Analysis ‣ Setup albo przycisk Setup Analysis):

a) uaktywnij analizę czasową (DC Sweep), dezaktywuj wszelkie inne;

b) kliknij Transient w celu otwarcia okna parametrów i wprowadź/zaznacz:

▪ wartość zmienianą jako napięcie źródła (Swept Var. Type: Voltage Source);

▪ rodzaj zmian jako liniowe (Sweep Type: Linear);

▪ nazwę źródła (Name) – V1x (x zmienić na cyfrę odpowiednio dla danego zespołu);

▪ wartość początkową (Start Value) – 0;

▪ wartość końcową (End Value) – 15;

▪ krok (Increment) – odpowiednio na podany przez prowadzącego.

18. Uruchom symulację. Upewnij się, że napięcie wyjściowe ma stałą wartość 5 V dla odpowiednio dużych 
napięć wejściowych (powyżej 5 V).

19. Dodaj nowy podwykres. Wyświetl (skopiuj) na nim charakterystykę napięcia wyjściowego uo w funkcji 
napięcia wejściowego.

20. Dodaj nowy podwykres. Wyświetl (skopiuj) na nim charakterystykę napięcia ugs w funkcji napięcia 
wejściowego.

21. Usuń pozostałe podwykresy/charakterystyki.

22. Zapisz obraz wykresów (menu Window ‣ Copy to Clipboard).
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23. Wprowadź schemat układu zgodnie z rysunkiem 2, przy czym:

a) nazwy modeli tranzystora, diody, kluczy sterowanych i układów scalonych są tożsame z ich 
oznaczeniami;

b) źródło napięcia  V3 należy wybrać jako element  VPWL_RE_FOREVER  i ustawić na nim następujące
parametry: FIRST_nPAIRS: (0s, 0); SECOND_nPAIRS: (91us, 5); THIRD_nPAIRS: (91.1us, 0) – odpowiada
to  przebiegowi  trójkątnemu  o  częstotliwości  około  110  kHz  (takiej  jak  w  przypadku  układu
badanego);

c) w obwodzie należy zdefigniować umowny węzeł masy, któremu zostanie przypisany numer 0 i 
potencjał 0 V – element GND_ANALOG.

24. Zmodyfigkuj oznaczenie każdego elementu tak, by kończyło się pełnym (nie jednocyfrowym) numerem 
zespołu.

25. Skonfigguruj symulację (menu Analysis ‣ Setup albo przycisk Setup Analysis):

a) uaktywnij analizę czasową (Transient), dezaktywuj wszelkie inne;

b) kliknij Transient w celu otwarcia okna parametrów i wprowadź:

▪ czas końcowy analizy (Final Time) – 0,1 s;

▪ krok zrzutu wyników do pliku tekstowego (Print Step, parametr nie używany w tej symulacji) – 
dowolny mniejszy od czasu końcowego;

▪ czas bez rejestracji wyników (No-Print Delay) – 0 (tj. rejestracja od początku symulacji);

▪ maksymalny krok czasowy (Step Ceiling) – brak ustawionego;

c) upewnij się, że opcja Skip initial transient solution nie jest zaznaczona.

26. W odpowiednim i nadającym się do tego celu miejscu dodaj znaczniki umożliwiające pomiar prądu 
wejściowego (źródło V1) i obciążenia (rezystor RL). 

27. Uruchom symulację. Upewnij się, że wykreślony przebieg prądu jest zgodny z zasadą działania układu w 
aspekcie kształtu oraz częstotliwości.

28. Ustal, po jakim czasie działanie układu stabilizuje się, tj. amplituda prądu odbiornika ustala się. Następnie
w opcjach analizy Transient - wprowadź tę wartość jako parametr No-Print Delay.

29. Dodaj nowy podwykres. Dodając odpowiednie znaczniki na schemacie, wyświetl na nim przebiegi 
napięcia wejściowego ui , napięcia ugs i napięcia wyjściowego uo, przy czym:

▪ zgodnie z instrukcją ogólną obsługi pakietu MicroSim/OrCAD, do wyświetlenia przebiegów nie 
jest konieczne ponowne uruchamianie symulacji, które usunęłoby dodany podwykres;

▪ znacznik potencjału może być wykorzystywany do pomiaru tylko takich napięć, które są 
odniesione do masy przypisanej w pkt. 23.c; inne napięcia muszą być mierzone znacznikiem 
napięcia (nie potencjału);

▪ w przypadku znaczników napięcia należy zachować polaryzację mierzonego napięcia zgodnie z 
rysunkiem powyżej (dla znacznika jest ona wskazywana przez znaki „+” i „−” w kółkach).

30. Upewnij się, że zgodnie z prawami i konwencjami teorii obwodów, wszystkie mierzone przebiegi mają w 
każdej chwili jednakowy znak. W przeciwnym razie:

a) sprawdź zgodność polaryzacji mierzonych napięć zgodnie z rysunkiem 2;

b) do prądu zastosuj uwagę z punktu 10.b.

31. Powtórz punkt 11.
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32. Zmodyfigkuj równanie przebiegu skopiowanego klikając dwukrotnie na jego podpisie, w taki sposób, by 
obecny podpis stał się argumentem funkcji AVG() - średnia krocząca.

33. Powtórz punkty 31 i 32 dla mocy wyjściowej.

34. Powtórz punkty 13 i 14.

35. Dla napięcia wejściowego podanego przez prowadzącego, uzyskaj i zapisz dane zastępujące wyniki 
pomiarów:

a) moc wejściową Pi  - ustawiając kursor na końcu symulacji;

b) moc wyjściową Po  - ustawiając kursor na końcu symulacji;

c) prąd wyjściowy Io  - ustawiając kursor na końcu symulacji;

d) napięcie wyjściowe (na odbiorniku) Uo  - ustawiając kursor na końcu symulacji.

36. Zapisz obraz przebiegów (menu Window ‣ Copy to Clipboard).

37. Usuń podwykres prądów i podwykres mocy.

38. Dodaj nowy podwykres. Wyświetl (skopiuj) na nim przbieg napięcia wyjściowego uo.

39. Dodaj nowy podwykres. Wyświetl (skopiuj) na nim przbieg napięcia ugs.

40. Usuń pozostałe podwykresy/przebiegi.

41. Ustaw oś czasu na przedział obejmujący około jednego pełnego okresu przebiegu napięcia ugs.

42. Zmieniając napięcie wejściowe od indywidualnej wartości i z krokiem podanym przez prowadzącego, 
uzyskaj (za pomocą kursorów) i zapisz dane zastępujące wyniki pomiarów:

a) czas trwania stanu wysokiego i okres przebiegu ugs;

b) średnią wartość napięcia wyjściowego (w połowie wysokości przebiegu);

c) międzyszczytową wartość tętnień napięcia wyjściowego (dla maksymalnego badanego napięcia 
wejściowego).

43. Zapisz obraz przebiegów dla maksymalnego badanego napięcia wejściowego (menu Window ‣ Copy to 
Clipboard).
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