Ćwiczenie nr 3. Symulacja analogowa w środowisku CADENCE z wykorzystaniem Analog Artist

Przedmiotem tego ćwiczenia będzie przeprowadzenie elementarnych analiz (stałoprądowej, przejściowej i częstotliwościowej) prostego wzmacniacza operacyjnego w pętli otwartej (rys. 1).
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rys. 1

Do przeprowadzania symulacji analogowych służy zintegrowane środowisko o nazwie Analog Artist, wywoływane z Design Framework II, które integruje narzędzia takie jak:

· netlister, czyli program generujący pliki opisujące obwód (odpowiedniki plików CIR w programie Spice) ze schematu zapisanego w programie Composer
· symulator (Spectre, Spectre-S, cdsSpice lub HSpice) przeprowadzający właściwą symulację

· Waveform Window służący do graficznej wizualizacji wyników symulacji w postaci wykresów (odpowiednik programu Probe w pakiecie MicroSim)

· Waveform Calculator, który umożliwia formułowanie skomplikowanych wyrażeń arytmetycznych bez znajomości składni ani listy dostępnych funkcji arytmetycznych oraz sam oblicza wielkości takie jak pasmo 3dB czy margines wzmocnienia i fazy

· Results Browser ułatwiający dostęp do wyników symulacji

· graficzny interfejs użytkownika umożliwiający w sposób wizualny ustawienie środowiska (np. ścieżki dostępu do modeli elementów), ustawienie parametrów symulacji, selekcję danych do zapisania i wyświetlenia, etc.)

W niniejszym ćwiczeniu symulacje będą przeprowadzane w oparciu o symulator Spectre. Jest to program działający na podobnej zasadzie co Spice, ale różniący się od niego zastosowanymi modelami elementów oraz składnią plików wejściowych.

Laboratorium nr 1. Przygotowanie i przeprowadzenie symulacji w Analog Artist

1. Z poziomu interpretera poleceń UNIX’a, przejść do podkatalogu analog w swoim katalogu domowym i uruchomić DF II poleceniem startcds &
2. Korzystając z programu Library Manager odszukać bibliotekę AnalogSim, a w niej celkę ampTop i otworzyć widok schematic
3. Obejrzeć schemat obwodu, w którym wzmacniacz jest symulowany oraz schemat samego wzmacniacza

a) Zaznaczyć na schemacie symbol wzmacniacza i wybrać polecenie Hierarchy -> Descend Read... (e) aby zobaczyć schemat samego wzmacniacza operacyjnego

b) Wybrać polecenie Hierarchy -> Return (Ctrl+e) aby powrócić do schematu nadrzędnego

c) Zaznaczyć źródło napięcia VIN dołączone do jednego z wejść wzmacniacza i wybrać polecenie Edit -> Properties (q) aby obejrzeć parametry tego źródła

4. Uruchomić środowisko Analog Artist poleceniem Tools -> Analog Artist
5. Ustawić środowisko symulacji

a) Z menu okna Analog Artist wybrać polecenie Setup -> Environment...
b) Wypełnić formularz w sposób pokazany na rys. 2 i kliknąć OK
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rys. 2

6. Wygenerować wstępną listę połączeń elementów

a) Z menu okna Analog Artist wybrać polecenie Simulation -> Netlist -> Create Final
b) Zapisać wygenerowaną listę połączeń do pliku o nazwie ampTop.cir wywołując polecenie File -> Save As w oknie, w którym lista została wyświetlona

c) Zamknąć okno i powrócić do Analog Artist
7. Ustawić wartości napięć zasilających wzmacniacz operacyjny

a) Z menu okna Analog Artist wybrać polecenie Setup -> Stimulus -> Edit Analog...
b) W formularzu, który się pojawił, w polu wyboru zaznaczyć opcję graphical i kliknąć OK. Otworzy się wtedy formularz pokazany na rys. 3
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rys. 3

c) W polu wyboru zaznaczyć Global Sources
d) W polu listy zaznaczyć źródło o nazwie vvdd
e) Zaznaczyć opcję Enabled (tzn. że jest aktywne)

f) W polu Function wybrać dc (źródło o stałej wartości)

g) W polu Type wybrać Voltage (źródło napięcia)

h) W polu DC voltage wpisać wartość 5 (tj. 5 V)

i) Kliknąć Apply aby zapamiętać zmiany

j) Zaznaczyć źródło o nazwie vvss i powtórzyć powyższe kroki, z tym że w polu DC voltage wpisać wartość –5 (tj. –5 V)

k) Kliknąć OK aby powrócić do okna Analog Artist
8. Ustawić parametry przeprowadzanych analiz

a) Z menu okna Analog Artist wybrać polecenie Analyses -> Choose...
b) W polu wyboru Analysis zaznaczyć tran
c) Wypełnić formularz w sposób pokazany na rys. 4
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rys. 4

d) W polu wyboru Analysis zaznaczyć dc
e) W polu wyboru Sweep Variable wybrać Component Parameter
f) Kliknąć przycisk Select Component i przejść do okna Composer zawierającego schemat obwodu

g) Kliknąć w źródło napięcia VIN. Pojawi się wtedy formularz pokazany na rys. 5
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rys. 5

h) Wybrać parametr dc i kliknąć OK aby powrócić do poprzedniego formularza

i) W polu Sweep Type wybrać Linear
j) Wypełnić resztę formularza w sposób pokazany na rys. 6
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rys. 6

k) W polu wyboru Analysis wybrać ac
l) W polu Sweep Type wybrać Logarithmic
m) Wypełnić resztę formularza tak jak pokazano na rys. 7
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rys. 7

n) Kliknąć OK aby zapisać zmiany i powrócić do okna Analog Artist
9. Określić zestaw wyników wyświetlanych dla poszczególnych analiz

a) Z menu okna Analog Artist wybrać polecenie Outputs -> Setup... Pojawi się wtedy okno o nazwie Setting Outputs
b) Dodać napięcie wyjściowe VOUT dla analizy DC
· Kliknąć przycisk New Expression
· Kliknąć przycisk Open w sekcji Calculator aby uruchomić Waveform Calculator
· W oknie kalkulatora zaznaczyć opcję Display Stack aby wyświetlić stos

· Kliknąć przycisk vs ( v = const )

· Przejść do okna Composer i na schemacie kliknąć na połączenie do węzła OUT
· Powrócić do kalkulatora. Powinno się w nim wyświetlać wyrażenie VS("/OUT")

· Przejść z powrotem do okna Setup Outputs i kliknąć przycisk Get Expression. W polu Expression powinno pokazać się wyrażenie VS("/OUT")

· W polu Name wpisać nazwę wyrażenia: DC output
· Kliknąć przycisk Apply aby zapamiętać wyrażenie

c) Dodać napięcie wejściowe VIN dla analizy TRANSIENT
· Przejść do okna kalkulatora i kliknąć przycisk vt ( v = v(t) )

· Przejść do okna Composer i na schemacie kliknąć w węzeł IN
· Powrócić do kalkulatora. Powinno się w nim wyświetlać wyrażenie VT("/IN")

· Przejść z powrotem do okna Setup Outputs i kliknąć przycisk Get Expression. W polu Expression powinno pokazać się wyrażenie VT("/IN")

· W polu Name wpisać nazwę wyrażenia: transient input
· Kliknąć przycisk Apply aby zapamiętać wyrażenie

d) Dodać napięcie wyjściowe VOUT dla analizy TRANSIENT w sposób analogiczny jak w poprzednim punkcie. Wyrażeniu temu nadać nazwę transient output
e) Dodać amplitudową charakterystykę częstotliwościową (analiza AC)

· Przejść do kalkulatora i kliknąć przycisk vf ( v = v(f) )

· Przejść do okna Composer i na schemacie kliknąć w węzeł OUT
· Powrócić do kalkulatora. Powinno się w nim wyświetlać wyrażenie VF("/OUT")

· Przejść do okna Composer i na schemacie kliknąć w węzeł IN
· Powrócić do kalkulatora, który powinien teraz wyświetlać wyrażenie VF("/IN")

· W oknie kalkulatora kliknąć przycisk "/". Wyświetlane wyrażenie powinno zmienić się na VF("/OUT") / VF("/IN")

· Kliknąć przycisk enter. Wyrażenie powinno zostać zapamiętane na stosie

· Zapisać powyższe wyrażenie do pamięci kalkulatora. W tym celu z menu wybrać polecenie Memories -> Store, nazwać wyrażenie gain i kliknąć OK
· Kliknąć przycisk mag (moduł). Wyświetlane wyrażenie powinno zmienić się na mag( VF("/OUT") / VF("/IN") )

· Przejść z powrotem do okna Setup Outputs i kliknąć przycisk Get Expression. W polu Expression powinno pokazać się wyrażenie mag( VF("/OUT") / VF("/IN") )

· W polu Name wpisać nazwę wyrażenia: magnitude(gain)

· Kliknąć przycisk Apply aby zapamiętać wyrażenie

f) Dodać fazową charakterystykę częstotliwościową (analiza AC)

· Przejść do kalkulatora i kliknąć przycisk dwn aby pobrać poprzednie wyrażenie ze stosu. Wyświetlane wyrażenie powinno zmienić się na VF("/OUT") / VF("/IN")

· Kliknąć przycisk phase (faza). Wyświetlane wyrażenie powinno zmienić się na phase( VF("/OUT") / VF("/IN") )

· Przejść z powrotem do okna Setup Outputs i kliknąć przycisk Get Expression. W polu Expression powinno pokazać się wyrażenie phase( VF("/OUT") / VF("/IN") )

· W polu Name wpisać nazwę wyrażenia: phase(gain)

· Kliknąć przycisk Apply aby zapamiętać wyrażenie

W rezultacie powyższych czynności okno Setup Outputs powinno wyglądać mniej więcej tak jak na rys. 8
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rys. 8

g) Kliknąć OK aby powrócić do okna Analog Artist, które powinno wyglądać mniej więcej tak jak pokazano na rys. 9
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rys. 9

10. Zapisać bieżącą sesję

a) Z menu okna Analog Artist wybrać polecenie Session -> Save State...
b) Wypełnić formularz tak jak pokazano na rys. 10 i kliknąć OK
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rys. 10

11. Na wszelki wypadek zapisać do pliku aktualną pamięć kalkulatora

a) Przejść do kalkulatora i z jego menu wybrać polecenie Memories -> Save...
b) Kliknąć OK aby zapisać pamięć kalkulatora do pliku o proponowanej nazwie

12. Przeprowadzić symulacje

a) Przejść do okna Analog Artist i z menu wybrać polecenie Simulation -> Run
b) Obserwować postęp symulacji (i ewentualne błędy) w głównym oknie icfb
c) W razie błędów z menu okna Analog Artist wybrać polecenie Simulation -> Output Log... aby wyświetlić bardziej szczegółowe informacje o błędach

d) Jeżeli symulacje zakończyły się pomyślnie to automatycznie zostanie wyświetlone okno Waveform Window z wynikami symulacji

Uwaga:

Nie zamykać żadnych otwartych okien.

Laboratorium nr 2. Obróbka i prezentacja wyników symulacji w oknie Waveform Window

1. Rozciągnąć okno Waveform Window na cały ekran aby uzyskać możliwie najlepszą rozdzielczość

2. Zmienić tytuły wszystkich trzech części okien

a) Zaznaczyć skrajną lewą część okna, dwukrotnie kliknąć w jej tytuł ("Expressions1") i zmienić go na "DC Characteristics"
b) Zaznaczyć środkową część okna, dwukrotnie kliknąć w jej tytuł ("Expressions2") i zmienić go na "Transient Response"
c) Zaznaczyć skrajną prawą część okna, dwukrotnie kliknąć w jej tytuł ("Expressions3") i zmienić go na "AC Characteristics"
3. Wyłączyć skrajną prawą część okna wyświetlającą charakterystyki częstotliwościowe

a) Z menu wybrać polecenie Window -> Subwindows... Pojawi się wtedy formularz pokazany na rys. 11
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rys. 11

b) W polu listy zaznaczyć okno nr 3, kliknąć przycisk Off a następnie OK
4. Zaznaczyć okno Transient Response i kliknąć przycisk Switch Axis Mode znajdujący się po lewej stronie okna, aby rozdzielić obydwa przebiegi czasowe na osobne wykresy

5. Zamienić miejscami wykresy VIN(t) i VOUT(t)

a) Z menu wybrać polecenie Edit -> Swap Strips
b) Kolejno kliknąć w obydwa wykresy. W wyniku tego zostaną zamienione miejscami

6. Włączyć wyświetlanie siatki w oknie Transient Response
a) Z menu wybrać polecenie Axes -> Options...
b) W polu wyboru Display zaznaczyć opcję grids (rys. 12) i kliknąć OK
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rys. 12

7. Wykreślić pochodną charakterystyki stałoprądowej po napięciu wejściowym

a) Zaznaczyć okno DC Characteristics
b) Z menu wybrać polecenie Tools -> Calculator aby przejść do kalkulatora

c) W oknie kalkulatora kliknąć przycisk wave
d) Przejść z powrotem do okna Waveform Window i kliknąć w charakterystykę DC

e) Powrócić do kalkulatora. Powinno się w nim wyświetlać wyrażenie VS("/OUT")

f) W oknie kalkulatora kliknąć przycisk Special Functions i wybrać funkcję deriv. Wyświetlane wyrażenie powinno zmienić się na deriv( VS("/OUT") )

g) Kliknąć przycisk plot aby wyświetlić pochodną na wykresie

8. W oknie Waveform Window zaznaczyć podokno DC Characteristics i kliknąć w przycisk Switch Axis Mode aby rozdzielić obydwa wykresy

9. Włączyć wyświetlanie siatki w podoknie DC Characteristics (Axis -> Options...)

10. Zapisać bieżące ustawienia wykresu do pliku o nazwie dc+tran  wywołując z menu polecenie Window -> Save i podając nazwę pliku

11. Włączyć część okna wyświetlające charakterystyki częstotliwościowe, a wyłączyć częsci okien wyświetlające charakterystyki DC i odpowiedź przejściową

a) Z menu wybrać polecenie Window -> Subwindows...
b) Korzystając z przycisków On i Off włączyć wyświetlanie okna nr 3, a wyłączyć wyświetlanie okien 1 i 2 (rys. 13) i kliknąć OK aby powrócić do okna wykresów
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rys. 13

12. Rozdzielić od siebie charakterystykę amplitudową i fazową na osobne wykresy i zamienić je miejscami oraz włączyć wyświetlanie siatki

13. Zmienić skalę osi wartości (Y) wykresu charakterystyki amplitudowej z liniowej na logarytmiczną wyskalowaną w dB

a) Z menu wybrać polecenie Curves -> Edit...
b) W formularzu (rys. 14) zaznaczyć krzywą nr 1 ( magnitude(gain) )
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rys. 14

c) W polu wyboru Scale wybrać db20 i kliknąć OK
14. Wykreślić charakterystykę Nyquista

a) Z menu okna Waveform Window wybrać polecenie Window -> Subwindows...
b) W formularzu kliknąć przycisk Add aby dodać nowe okno, a następnie OK aby powrócić do wykresów

c) Zaznaczyć nowe okno i z menu wybrać polecenie Annotation -> Edit -> Subtitle...
d) Wpisać nową nazwę okna: "Nyquist Characteristics" i kliknąć OK
e) Przejść do kalkulatora (poleceniem Tools -> Calculator)

f) Z menu kalkulatora wybrać polecenie Memories -> Recall...
g) W polu listy formularza (rys. 15) wybrać parametr gain i kliknąć OK. Kalkulator powinien wyświetlić wyrażenie mag( VF("/OUT") / VF("/IN") )
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rys. 15

h) Kliknąć przycisk enter aby zapamiętać powyższe wyrażenie na stosie

i) Kliknąć przycisk real (część rzeczywista). Kalkulator powinien wyświetlić wyrażenie real( VF("/OUT") / VF("/IN") )

j) Kliknąć przycisk plot aby wyświetlić krzywą odpowiadającą części rzeczywistej na wykresie

k) Zaznaczyć wyświetlony wykres i z menu okna Waveform Window wybrać polecenie Axes -> X Axis... Pojawi się wtedy formularz pokazany na rys. 16
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rys. 16

l) W polu wyboru Plot vs. wybrać część rzeczywistą VOUT / VIN  (rys. 16) i kliknąć OK
m) Powrócić do kalkulatora i kolejno kliknąć przyciski: down i enter. Kalkulator znowu powinien wyświetlać wyrażenie VF("/OUT") / VF("/IN")

n) Kliknąć przycisk imag (część urojona). Kalkulator powinien wyświetlić wyrażenie imag( VF("/OUT") / VF("/IN") )

o) Kliknąć przycisk plot aby zakończyć wyświetlanie charakterystyki Nyquista

15. Zapisać ustawienia wykresów do pliku o nazwie ac (polecenie Window -> Save...)

16. Odczytać z wykresów najważniejsze parametry częstotliwościowe wzmacniacza w pętli otwartej

a) Odczytać maksymalne wzmocnienie w paśmie (w dB)

· Zaznaczyć część okna wyświetlającą charakterystykę amplitudową i fazową

· Uaktywnić jeden z celowników: A (polecenie Chrosshair -> Marker A (a)) lub B (polecenie Chrosshair -> Marker B (b))

· Najechać celownikiem na płaski fragment wykresu charakterystyki amplitudowej i kliknąć lewym przyciskiem myszy

· Odczytać i zanotować wartość wzmocnienia (w dB) wyświetloną pod wykresami (współrzędną Y celownika)

b) Odczytać szerokość pasma 3-decybelowego

· Uaktywnić jeden z celowników i obserwować jego współrzędne wyświetlane pod wykresami

· Najechać na fragment charakterystyki, w którym wartość wzmocnienia (współrzędna Y celownika) jest mniejsza od maksymalnej o 3 dB i kliknąć lewym przyciskiem myszy w to miejsce

· Odczytać i zanotować wartość pasma wyrażoną w Hz (współrzędna X celownika)

c) Wykorzystując obydwa celowniki naraz odczytać z charakterystyki amplitudowej i fazowej margines amplitudy i margines fazy

· Margines amplitudy to wartość charakterystyki amplitudowej dla częstotliwości, przy której charakterystyka fazowa przecina oś odpowiadającą -180(
· Margines fazy to 180( minus wartość charakterystyki fazowej dla częstotliwości, przy której charakterystyka amplitudowa przecina oś odpowiadającą 0 dB

17. Wykorzystując program Waveform Calculator zweryfikować wartości parametrów odczytane z wykresów

a) Przejść do kalkulatora i kliknąć przycisk down. Kalkulator powinien wyświetlić wyrażenie VF("/OUT") / VF("/IN")

b) W polu wyboru Special Functions wybrać funkcję bandwith. Pojawi się wtedy formularz pokazany na rys. 17
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rys. 17

c) W polu wyboru Type wybrać low (tzn. że dotyczy pasma dolnoprzepustowego)

d) W polu Db wpisać 3 (tzn. że ma być obliczone pasmo 3-decybelowe)

e) Kliknąć OK aby powrócić do okna kalkulatora. Kalkulator powinien wyświetlić wyrażenie bandwidth( VF("/OUT") / VF("/IN"), 3, "low" )

f) Kliknąć przycisk print aby odczytać szerokość pasma 3dB. Porównać otrzymaną wartość z wartością odczytaną poprzednio z wykresu

g) Kliknąć przycisk down. Kalkulator powinien ponownie wyświetlić wyrażenie VF("/OUT") / VF("/IN")

h) W polu wyboru Special Functions wybrać funkcję gainMargin. Kalkulator powinien wyświetlić wyrażenie gainMargin( VF("/OUT") / VF("/IN") )

i) Kliknąć przycisk print aby odczytać szerokość margines amplitudy. Porównać otrzymaną wartość z wartością odczytaną poprzednio z wykresów

j) W analogiczny sposób odczytać margines fazy powtarzając kroki g-i z zastosowaniem funkcji phaseMargin i porównać go z wartością odczytaną z wykresów
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