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Cwiczenie 2. Falownik rezonansowy szeregowy (22.4.2006) 3

1. Wstep

Celem ¢wiczenia jest poznanie zasady dzialania jednego z typowych ukladow
przeksztaltnikowych AC/DC (falownikéw). Przykladowy uklad stanowi niezalezny
falownik rezonansowy szeregowy, w ktérym role kluczy pelnia poétsterowalne przyrzady
potprzewodnikowe mocy — tyrystory. Badania uktadu dotycza wplywu elementéw obwodu
rezonansowego i parametréow sterowania na prace ukladu jako calosci oraz na warunki
pracy tyrystoréw. Na podstawie wynikdw analizy widmowej dokonywana jest ocena jakosci
pracy uktadu w zaleznosci od parametréw sterowania.

Niniejsze ¢wiczenie nie wyczerpuje zagadnienia przeksztattnikow DC/AC. Istniejg inne
rozwigzania falownikdw rezonansowych, jak réwniez falowniki inne niz rezonansowe (np.
falowniki impulsowe). Ich szczegélowa analiza wykracza jednak poza zakres niniejszego
laboratorium.
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4 Podstawy energoelektroniki

2. Podstawy teoretyczne

2.1. Wprowadzenie

Falowniki szeregowe sa urzadzeniami stuzacymi do przeksztatcania napiecia statego na
prad przemienny. Przeksztaltniki te nazywane sa falownikami niezaleznymi i, w
odréznieniu od falownikow sieciowzbudnych (zaleznych), nie maja potaczenia od strony
wyijscia ze sztywna siecig energetyczna.

Falowniki szeregowe znajdujq zastosowanie m.in. w grzejnictwie indukcyjnym, technice
ultradzwigkowej, napedach elektrycznych, uktadach przetwarzania napie¢ itp.

a) A

Rys. 1. Uktad podstawowy falownika rezonansowego szeregowego:
a) schemat uktadu; b) przebiegi napiec i pradéw
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Cwiczenie 2. Falownik rezonansowy szeregowy (22.4.2006) 5

2.2. Zasada dziatlania falownika szeregowego - uktad podstawowy

W falowniku szeregowym odbiornik (na rys. 1 opornik R) wchodzi w skfad szeregowego
obwodu rezonansowego. Warunkiem poprawnej pracy falownika jest, aby obwdd RLC byt
obwodem drgajacym, co sprowadza si¢ do warunku

L
R<2\/;. (1)

Zasada pracy ukladu jest nastepujaca: po wilaczeniu tyrystora T:i nastepuje
przetadowanie rezonansowe kondensatora C (od napiecia —-Ux do napiecia E+lUx)
praktycznie sinusoidalnym impulsem pradu i.. Po chwilowej zmianie kierunku pradu,
tyrystor T1 wylacza si¢. Na kondensatorze napiecie zostaje podtrzymane przez czas top, a po
wlaczeniu tyrystora Tz, kondensator zostaje przeladowany do napiecia —Ux. W obciazeniu
pojawia sie¢ drugi impuls stanowiacy ujemny podtokres pradu przemiennego. Tyrystor Tz
wylacza sie z chwila zmiany kierunku pradu.

Obwdd drgajacy RLC mozna opisa¢ nastepujacymi wielkosciami:

* wo - pulsacja drgan wilasnych niettumionych
W) =——; )
* o - wspdlczynnik ttumienia
oa=—. 3)

Ttumienie obwodu moze tez by¢ okreslone przez:

*  aw-wzgledny wspdtczynnik ttumienia

ay, Zizﬁ\/é; 4)
o, 2\VL

* o - pulsacje drgan wiasnych ttumionych

a):\/a)g—az :a)o\/l—avzv; )

= (Q-dobro¢:

(6)

W tym ukiadzie falownika czas opdznienia przerzutu top jest réwny czasowi
dysponowanemu na wylaczenie tyrystora ts. Poniewaz tyrystor musi odzyskac¢ wtasnosci
blokujace w czasie t4, dlatego tez czas top = ta nie moze by¢ mniejszy od czasu wylaczania
tyrystora tq, co wyraza si¢ nastepujacym warunkiem:

tg =ty 1. (7)
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6 Podstawy energoelektroniki

Czestotliwos¢ pracy ukladu — narzucona przez czestotliwos¢ sterowania fs — jest wiec
mniejsza niz czestotliwos¢ rezonansowa f obwodu RLC. To ograniczenie od gory
czestotliwosci pracy uktadu jest jego podstawowa wada.

2.3. Uklad zmodyfikowany falownika szeregowego

Wade uktadu opisanego w par. 2.2 mozna w znacznym stopniu usuna¢, stosujac cewki
sprzezone o rownych indukcyjnosciach L1 = Lz (rys. 2).

Rys. 2. Schemat zmodyfikowanego uktadu falownika szeregowego.

Rozwazmy dziatanie tego ukladu: tyrystor Ti przewodzil, kondensator C jest
natadowany do napiecia E+Ux. Proces tadowania kondensatora jest analogiczny do procesu
fadowania opisanego w poprzednim punkcie. Po zataczeniu tyrystora T2, prad ptynie przez
cewke L2 indukujac na niej pewne napiecie. Dzigki wzajemnemu sprzezeniu L1 i L2, na cewce
L: powstaje rowniez napigcie, ktore zostaje doprowadzone do Ti jako dodatkowe napigcie
wsteczne zwigkszajace czas dysponowany na wylaczenie o pewng wartos¢ t«:

lg=loy+1s 21, (8)

Mozna wigc wlaczy¢ jeden tyrystor nim drugi odzyska wilasciwosci blokujace, co
prowadzi do zmniejszenia czasu opdznienia przerzutu. Rozwazany uktad moze pracowac z
czestotliwoscig sterowania:

* fi<f-najwigkszy czas dysponowany t4, duze znieksztalcenia pradu
odbiornika (rys. 3a);

* fi=f-przypadek dopasowania, najkorzystniejszy ksztalt pradu
odbiornika (rys. 3b);

* fi>f—przebieg pradu prawie prostokatny, duze stromosci pradu i
napiecia oraz maty czas dysponowany td (rys. 3c).
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fof>f

Rys. 3. Typowe przebiegi w uktadzie zmodyfikowanym falownika szeregowego: a) fs<f; b) fs
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Wzory opisujace najwazniejsze parametry sg nastepujace:

B exp(—naw/qll—aé )
U _El—exp(—ﬁaw/\/l—ai )’ v
E

exp(— a, /\/1 —al );

E+U, = (10)

zatem

Us :exp(—ﬁaw/M). (11)

E+U,

Stromos¢ napieciowa moze by¢ obliczona ze wzoru

py = Ea)[tg¢+tg(a)tX +¢)]. (12)

1=ty

Istnieje szereg odmian uktadowych szeregowego falownika rezonansowego. Jedna z nich
pokazana jest na rys. 4. Uklady praktyczne falownikoéw zostaty obszernie przedstawione w
literaturze.

o

Rys. 4. Jedna z wersji uktadu falownika szeregowego

2.4. Wspotczynnik zawartosci harmonicznych

Ogolnie rzecz biorac, zadaniem falownikéw — jako przeksztattnikow DC/AC — jest
generacja przemiennego sygnatu sinusoidalnego. W takim przypadku, aby oceni¢ jakos¢
dziatania ukfadu, nalezy dysponowac jakas miarg podobienistwa generowanego przebiegu
(w rozwazanym ukladzie jest to prad odbiornika io) do idealnej sinusoidy. Takim
parametrem jest wspotczynnik zawartosci harmonicznych dn (ang. total harmonic distortion,
THD). Inne spotykane nazwy tego wspolczynnika to wspodlczynnik znieksztatcen
harmonicznych lub wspoétczynnik odksztatcenia harmonicznymi.
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Cwiczenie 2. Falownik rezonansowy szeregowy (22.4.2006) 9

Wspolczynnik zawartosci harmonicznych definiuje si¢ z reguly jako stosunek wartosci
skutecznej obliczonej (ze wzoru Parsevala) z pominieciem pierwszej harmonicznej do
wartosci skutecznej pierwszej harmoniczne;:

dh :_k:Z 7 (13)

gdzie X® oznacza wartos¢ skuteczng k-tej harmonicznej danego sygnatu x(t). Te definicje
przyjmuja m. in. obowigzujace normy dotyczace jakosci zasilania oraz oddzialywania
odbiornikéw na siec zasilajaca.

W praktyce, gdy korzystamy z cyfrowych przyrzadéw pomiarowych, znane sa wartosci
skuteczne jedynie pewnej skonczonej liczby harmonicznych N. Zachodzi wdweczas
koniecznos¢ stosowania wzoru przyblizonego:

A — (14)

Przyjmuje si¢, ze dla typowych przebiegow wystarczajaca dokladnos¢ osiaga sie dla
N = 40-50.

Jak nietrudno zauwazy¢, dla sinusoidy dn=0, gdyz zawiera ona tylko harmoniczng
podstawowaq (pierwsza). Natomiast im wigkszy wspolczynnik zawartosci harmonicznych,
tym wigksze odksztatcenie przebiegu od idealnej sinusoidy.
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10 Podstawy energoelektroniki

3. Badanie ukfadu

3.1. Uklad pomiarowy

Uktad pomiarowy pozwala na badanie falownika szeregowego w ukladzie
symetrycznym (jak na rys. 4) lub niesymetrycznym (jak na rys. 2 bez cewki Ls).

Przetaczniki umozliwiajg zmiane:
* wartosci indukcyjnosci obwodu rezonansowego L (= L1 = L2),
* wartosci rezystancji obciagzenia R,
* Kkonfiguracji (A — niesymetryczna, B — symetryczna).
Uklad jest tak skonstruowany, Ze niezaleznie od konfiguracji wypadkowa pojemnos¢ C w
szeregowym obwodzie rezonansowym wynosi 3,75 uF.
Do oscyloskopu nalezy podtaczyc¢:

* dojednego z kanaléw — sygnat z wyjscia uktadu I (pomiar pradu) za
posrednictwem zwyklego kabla koncentrycznego;

* do drugiego kanatu — sygnat z wyjscia U (pomiar napiecia) przez sonde
thumiaca 10:1, przy czym mase sondy nalezy pozostawic nie podtaczona;

* do wejscia wyzwalania zewnetrznego — sygnat z wyjscia Synchr.
Pomiar pradu odbywa si¢ za posrednictwem bocznikéw o wartosci 10 mQ.

Przyciskiem umieszczonym ponizej gniazd I i U wybiera si¢ jedng z dwoch par
przebiegéw do obserwagiji:
* napiecie —uciprad i;
* lub napiecie um i prad —it.
Przycisk ponizej gniazda Synchr. pozwala wybra¢ miedzy wyzwalaniem oscyloskopu

rownoczesnie z wyzwoleniem tyrystora T1 lub réwnoczesnie z wyzwoleniem tyrystora T>. W
niniejszym ¢wiczeniu ustawienie to moze by¢ dowolne.

Pokretto Regq.f stluzy do regulacji czestotliwosci wyzwalania tyrystorow fs. Nalezy
nadmieni¢, ze przy maksymalnym docigzeniu uktadu (wybér R = 0) nastepuje samoczynne
obnizenie czestotliwosci wyzwalania.

Do rejestracji i przetwarzania przebiegéow z oscyloskopu wykorzystuje si¢ program
SP107 dostepny z menu Start, zakladka Pomiary. Pobrania przebiegéw aktualnie
wyswietlanych na ekranie dokonuje si¢ przyciskiem Read. Jezeli zglaszany jest brak facznosci
z oscyloskopem, nalezy skonfigurowac polaczenie wciskajac przycisk Config i Autosearch, a
nastepnie przestawiajac predkos¢ potaczenia na 115200 baud. Zapisu przebiegéw w formie
numerycznej dokonuje si¢ z menu Data » Save, a w formie obrazu — przyciskiem WMF-
Export; obraz mozna réwniez skopiowac do schowka z menu Data » Clipboard.

Zgodnie z instrukcja, wyniki analizy Fouriera zapisujemy w arkuszu kalkulacyjnym. W
laboratorium dostepny jest arkusz kalkulacyjny pakietu OpenOffice. Jezeli przy
uruchamianiu pojawi si¢ informacja o koniecznosci dokonania instalacji, nalezy ja
przeprowadzi¢ zgadzajac si¢ na wszystkie domyslne ustawienia, bez wypetiania danych i
rejestrowania programu. Obstuga arkusza kalkulacyjnego w zakresie potrzebnym na
laboratorium jest identyczna z programem Microsoft Excel. Aby bezproblemowo odczytac
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Cwiczenie 2. Falownik rezonansowy szeregowy (22.4.2006) 11

arkusz w programie Microsoft Excel, nalezy na koniec zapisa¢ go w formacie XLS (menu
Plik, Zapisz jako).

3.2. Program badan

1.

Wprowadzic¢ na oscyloskopie odpowiednie ustawienia:

a) wylaczy¢ uwzglednianie ttumienia sondy 10:1 na kanale, do ktoérego przytaczono
wyjscie I — wcisnac i przytrzymac (do sygnatu dzwiekowego) przycisk AC DC obok
wejscia kanatu (uwzglednianie thumienia jest sygnalizowane wyswietlaniem symbolu
sondy po lewej stronie wzmocnienia danego kanatu);

b) wilaczy¢ uwzglednianie ttumienia sondy 10:1 na kanale, do ktérego przylaczono
sonde napieciowa;

c) sprawdzi¢, czy na obu kanatach ustawione jest sprzezenie DC (sprzezenie DC jest
sygnalizowane przez znak = obok nazwy kanatu na dole ekranu, zas sprzezenie AC —
przez znak ~; zmiany dokonuje si¢ wciskajac (krétko) przycisk AC DC);

d) wybra¢ wyzwalanie z wejscia zewnetrznego (EXT — wybor przyciskiem pod
kontrolkami TRIG.);

e) ustawic tryb wyzwalania wysoka czestotliwoscia HF (przycisk TRIG. MODE);

f) jezeli oscyloskop nie wyzwala si¢ poprawnie (nie swieci si¢ kontrolka TR lub obraz
jest niestabilny), nalezy wyregulowac poziom wyzwalania (pokretto LEVEL);

g) wzmocnienia kanatéw powinny by¢ takie, aby obserwowane przebiegi zajmowaty
mozliwie duza czes¢ ekranu (w trakcie pomiaréw nalezy dopasowywac to
ustawienie do zmieniajacych si¢ warunkow).

W celu eliminacji szuméw widocznych szczegélnie na przebiegu napiecia na boczniku mozna
na oscyloskopie wlaczy¢ tryb usredniania. W tym celu nalezy strzatkami STOR. MODE
wybra¢ AVM, wywota¢ funkcje #AV (wcisnac¢ obie strzatki jednoczesnie), ustawié strzatkami
liczbe probek, z ktérych ma by¢ obliczana srednia, i zatwierdzi¢ wciskajac ponownie #AV.

Ustawi¢ czestotliwos¢ pracy (sterowania) fs < f. Relacje miedzy f a fs nalezy okresli¢ w
oparciu o obserwowane oscylogramy i wstep teoretyczny (par. 2.3).

Podstawe czasu nalezy dobra¢ tak, aby poézniej mozliwe bylo w miare dokladne
zmierzenie odpowiednich czaséw (na ekranie widoczne ok. 2 okresy). W razie potrzeby
przebiegi mozna przesuwac o 1/4 ekranu w prawo przyciskiem PTR. (pre-trigger).

Zarejestrowac przebiegi dla wszystkich 6 kombinacji wartosci Ri L.

Nalezy zarejestrowad wszystkie dostepne przebiegi napie¢ i pradow przy rozsadnej
podstawie czasu, dla konfiguracji ,A”. Aby mozliwe bylo tatwe odczytanie poziomow
napie¢ i dlugosci odcinkéw czasowych z uzyciem kursorow programu SP107,
oscylogramy nalezy zapisywac¢ w formacie MES.

Ustawic¢ wartosci L i R wedtug zalecenia prowadzacego (pozostawic¢ konfiguracje ,,A”).

Dla 5-6 wartosci czestotliwosci sterowania fs z dostepnego zakresu (uwzgledniajac

wszystkie przypadki: s <f, fs=f, fs > f):

a) zarejestrowac przebieg pradu odbiornika przy takiej podstawie czasu, aby widoczne
byly co najmniej 4 okresy pradu;

b) zapisac przebieg w postaci obrazu;
c) dodatkowo zapisa¢ wyniki w postaci tabelarycznej w pliku tekstowym (TAB);
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12 Podstawy energoelektroniki
d) dla dowolnego z przypadkow fs<f wyznaczy¢ i zapisa¢ czestotliwos¢ drgan
wlasnych f.
6. Uruchomic program Scilab stuzacy do obliczen numerycznych. Wczytac plik zawierajacy
funkcje potrzebne w niniejszym ¢wiczeniu, wpisujac instrukcje:
exec ("\\ixi\labs\common\pee\falownik.sce');
7. W programie Scilab dla kazdego z zapisanych plikéw TAB obliczy¢ widmo amplitudowe

pradu odbiornika:

a)

b)

d)

f)

g)

wezytac¢ wyniki z pliku tekstowego do macierzy naglowek i dane, wpisujac komende:
[naglowek,dane]=wczytaj spl07('nazwa pliku.tab');

za pomocy trasformaty Fouriera obliczy¢ czestotliwos¢ sterowania fs oraz amplitudy
harmonicznych, wpisujac komende:

[widmo, fs]=fftfal (dane, nr kolumny t, nr kolumny io, ki);

gdzie nr_kolumny_t i nr_kolumny_io oznaczaja numery kolumn w pliku TAB
zawierajagce odpowiednio czas t i napigcie na boczniku ui, natomiast ki jest
mnoznikiem pozwalajacym przeliczy¢ napiecie na boczniku uic na rzeczywisty
wartos¢ pradu odbiornika i.. Podpisy (nagltowki) kolumn w pliku TAB mozna
wyswietli¢ wpisujac:

naglowek
odczytad i zanotowac czestotliwos¢ sterowania fs wpisujac:

fs

wykreslic w postaci stupkéw widmo amplitudowe pradu odbiornika do 40.
harmonicznej wlacznie, wpisujac:

fft wykres(widmo,40);

zapisa¢ obraz widma: w oknie wykresu wybra¢ z menu File » Export, a nastepnie
Export Type: GIF.

skopiowac obliczone widmo amplitudowe do schowka w postaci tabelki, wpisujac:
fft kopiuj (widmo) ;

wklei¢ widmo ze schowka do czystego arkusza w arkuszu kalkulacyjnym
OpenOffice.

3.3. Opracowanie wynikow

Wptyw parametrow obwodu rezonansowego

1.

Na podstawie przebiegdw zarejestrowanych w punkcie 3.2.3, dla wszystkich

przypadkéw wyznaczyc¢:

a)

czestotliwos¢ drgan wlasnych f;
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Cwiczenie 2. Falownik rezonansowy szeregowy (22.4.2006) 13

b) czas opdznienia wewnetrznego ty;
c) wartosci napiec¢ Uxi E+Ux;

d) wartosci maksymalnych napiec¢ wystepujacych na tyrystorze w kierunku blokowania
(Urm) i w kierunku wstecznym (Urw);

e) maksymalng stromos$¢ narastania napigcia blokowania (dup/dt)max.

W tym celu nalezy zlokalizowa¢ przedziat czasu tx i zaznaczy¢ na nim kursorami odcinek
(wybrany ,na oko”), na ktérym stromos¢ napiecia um jest maksymalna. Stromos¢ te
oblicza sie jako Aup/At na podstawie obliczonej przez program réznicy potozen kursorow:
(1) Aup — wskazanie ,CI - CII” dla kanalu zawierajacego przebieg uri; (2) At — wskazanie
Ldt”.

Otrzymane wyniki zebra¢ w tabeli.

Na podstawie wynikéow z punktu 1 przeanalizowa¢ wplyw parametréw obwodu
rezonansowego na czestotliwos¢ generowanych drgan.

Wykresli¢ czas opdznienia wewnetrznego tx w funkgcji rezystangji R (na jednym wykresie
dwie krzywe — dla dwu wartosci L). Na tej podstawie okresli¢ wplyw parametréw Ri L
na czas tx. Jak wobec tego zmienia si¢ wymagania co do parametru tq (czasu wylaczania)
tyrystorow: (a) przy zwigkszeniu rezystancji obcigzenia? (b)przy zwiekszeniu
indukcyjnosci obcigzenia?

Wykresli¢ maksymalna stromos¢ narastania napiecia blokowania (dup/dt)mx w funkcji
rezystancji R dla obu wartosci L. Przeanalizowa¢ wplyw tych parametréw; czy warunki
pracy tyrystoréw sa korzystniejsze dla matych czy dla duzych obciazen?

Na podstawie wyznaczonych wartosci Ux i E+Ux, obliczy¢ wspodtczynnik ttumienia aw, a
nastepnie (na podstawie obliczonej wartosci aw) dobro¢ obwodu rezonansowego Q.
Wyniki doda¢ do tabeli.

Wykresli¢ zalezno$¢ maksymalnych napie¢ Urv i Utw od dobroci uktadu rezonansowego.
Sformutowac wniosek dotyczacy warunkéw pracy tyrystorow.

Wplyw czestotliwosci pracy falownika

7.

10.

Dla kazdego przypadku =z punktu 3.2.5 obliczy¢ wspdtczynnik zawartosci
harmonicznych dn biorac pod uwage N =20 harmonicznych.

Obliczenia najprosciej wykonaé¢ w arkuszu kalkulacyjnym, wpisujac odpowiednia formute z
uzyciem funkcji SUMA() i PIERWIASTEK() [w wersji angielskiej: SUM() i SQRT()]. Potrzebne
bedzie dodanie nowej kolumny z wyliczonymi kwadratami wartosci skutecznych.

Przeanalizowa¢ wyniki — powiaza¢ obraz przebiegdw w funkcji czasu, obraz widma i
wartos¢ wspolczynnika zawartosci harmonicznych.

Dla kazdego przypadku wyznaczy¢ stosunek fs/f korzystajac z wartosci f wyznaczonej w
punkcie 3.2.5.d).

Zebra¢ w tabeli uzyskane wyniki f;, fs/f i dn. Wykresli¢ zaleznos¢ wspdtczynnika dn od
stosunku fs/f. Sformutowac wnioski.
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4. Oczekiwana zawartosc¢ sprawozdania

Sprawozdanie powinno zawierac:
* tabele z wynikami z punktow 3.3.11 3.3.10;

* przykladowe przebiegi i obrazy widma zarejestrowane w punktach 3.2.5 i
3.2.7 (dla trzech przypadkow — fs réwnego, wigekszego i mniejszego od f);

* wykresy, ich analize i wnioski zgodnie z poleceniami w par. 3.3.

W katalogu sieciowym zespotu nalezy pozostawic pliki z zarejestrowanymi przebiegami
i uzyskanymi wynikami.
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